MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

View previous topic View next topic Go down

MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  IsambardKingdomBrunel on Thu 11 Feb 2016, 10:46 pm

Does anyone know of a working fix for power cars missing from Class 105 sets, when MEP is run in OR (they work fine in MSTS).

Also is there a solution to incorrect functionality of UK Distant and combined Home\Distant semaphore signals.

Many instances of this problem in a few UK routes, including Thames - Trent v2, Bala Hub v4.2, S&DJR Line, to name a couple.

Any help would be gratefully received.

Mike.
avatar
IsambardKingdomBrunel

Posts : 36
Join date : 2013-07-22
Age : 66
Location : South West Wales

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  StephenRWells on Fri 12 Feb 2016, 11:48 am

Hi Mike,

For the Class 105 DTCL cars the problem appears to be the lack of exhaust scripts in the section:-
Engine ( MEP-Cravens105
Effects
(
DieselSpecialEffects
(

Copy this complete section in from the DMBS, then in the DieselSmokeEffects section reduce everything to just above zero and you should now have your DTCL visible.

As far as the Distant and Home/Distant signals are concerned this is do with the signal scripting which is beyond me. This could also explain why some signal lights are invisible on their posts - both semaphore and electric.

I hope that I have helped with part of your problem,

Stephen
avatar
StephenRWells

Posts : 428
Join date : 2013-07-15
Age : 66
Location : Arncott,Oxfordshire

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  IsambardKingdomBrunel on Fri 12 Feb 2016, 1:42 pm

Hi Stephen,

many thanks for taking the time to help.

I will give that a try with the 105 thanks buddy.

In regards the semaphore Distant and Combined sigs.

In the past i have posted bug reports on the OR reporting site.

Posted on Elvas Tower, but i don't think there is much interest in the functionality of UK semaphores.

Same as you with the scripts Stephen, i have tried fiddling with them, but to no avail.

Thank you again for your help with the Class 105 problem.

regards,
Mike.
avatar
IsambardKingdomBrunel

Posts : 36
Join date : 2013-07-22
Age : 66
Location : South West Wales

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  rufuskins on Fri 12 Feb 2016, 4:18 pm

I would like to point out that the DTCL unit in a Class 105 set was a driving trailer and therefore had no engine and consequentially no exhaust!


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3364
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  StephenRWells on Fri 12 Feb 2016, 4:48 pm

Hi Alec,

Perfectly true, but all the same if you are to drive a DTCL both MSTS and Open Rails expects the engine to be there so that there is also a working cabview present. Open Rails also expects working exhausts to be present - hence my solution.

Regards,

Stephen
avatar
StephenRWells

Posts : 428
Join date : 2013-07-15
Age : 66
Location : Arncott,Oxfordshire

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  slipperman12 on Fri 12 Feb 2016, 7:14 pm

Hi Stephen,
The neatest way to sort out the Class 105 DTCL is to remove the Diesel Effects section completely - after all, it shouldn't be there for a non-powered vehicle! Open Rails will then accept it, although I can't get much speed out of it!!

Cheers,
Ged

slipperman12

Posts : 1264
Join date : 2013-01-29
Age : 75
Location : North Nottinghamshire

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  rufuskins on Fri 12 Feb 2016, 7:16 pm

I know that for a two car set with the DTCL leading it is necessary to provide it with an engine as I did for the many DMU sets I painted for UKTS upload. However I didn't realise that OR throws a wobbly if a drivable unit doesn't have an exhaust? Shocked Shocked Shocked


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3364
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  slipperman12 on Fri 12 Feb 2016, 8:08 pm

Hi Alec,
It appears that Open Rails objects to a Diesel Effects section with no effects!!

Cheers,
Ged

EDIT : While we're discussing the Class 105 DTCL, it appears to be using the wrong sms files.  It should be using the DMUengTrailer.sms and DMUcabTrailer.sms instead of DMUeng.sms and DMUcab.sms. Also, the DMUcab.sms has no horn!

slipperman12

Posts : 1264
Join date : 2013-01-29
Age : 75
Location : North Nottinghamshire

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  dforrest on Sat 13 Feb 2016, 11:06 am

I raised the issue at Elvas Tower again and this was the response:

There are several small quirks in the signaling framework that need ironed out. I haven't yet taken the time to determine how well and when the dist_multi_sig_mr() function may be mis-behaving in OR, but another thread was just started talking about it, too. I am hoping the things I've already noticed won't be too hard to fix. It isn't just UK absolute block semaphores that use functions like dist_multi_sig_mr(). My American signals make extensive use of it, too.

This is at http://www.elvastower.com/forums/index.php?/topic/28215-incorrect-functionality-of-uk-distant-and-combined-homedistant-semaphore-signals/ for those who have access to the Elvas Tower forums.


David
avatar
dforrest

Posts : 399
Join date : 2013-01-21
Age : 71
Location : St. Vincent and the Grenadines (and in an earlier life, Hull)

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  rufuskins on Sat 13 Feb 2016, 1:29 pm

Just to clarify the situation with the trailer type units for FG DMU sets that I uploaded to UKTS; here is what I did.

1. When the Motor unit was leading it was defined as an "Engine" and was provided with diesel exhaust effects, whilst the Trailer unit was defined as a "Carriage" and obviously no diesel exhaust effects were provided.

2. When the Trailer unit was leading it was redefined as an "Engine" and included the diesel exhaust effects and the Motor unit was redefined as a "Carriage" and hence no diesel exhaust effects were provided.

I would therefore imagine that those uploaded to UKTS by myself ought to work in Open Rails.


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3364
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  IsambardKingdomBrunel on Sun 14 Feb 2016, 1:43 pm

I couldn't understand where to insert your line of code in the 105 trailers, sorry Stephen.

Must be getting old or senile or both Smile

In regards the Distant signals, the response on Elvas Towers, was better than i have ever elicited from them.

Spent about 2 years reporting the problem on their bug reporting software and was always told it needed sorting out in the signal script files.

Which is no help at all to someone who does not understand the scripts.

All i know as a BR apprentice i had to spend a part of my time learning with the Signalling Section and so have a good grounding in how the real world works.

Mike.
avatar
IsambardKingdomBrunel

Posts : 36
Join date : 2013-07-22
Age : 66
Location : South West Wales

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  IsambardKingdomBrunel on Sun 14 Feb 2016, 1:44 pm

Sorry guys just spotted double post.

Mike.


Last edited by IsambardKingdomBrunel on Mon 15 Feb 2016, 1:56 pm; edited 1 time in total (Reason for editing : Unintentional double post.)
avatar
IsambardKingdomBrunel

Posts : 36
Join date : 2013-07-22
Age : 66
Location : South West Wales

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  StephenRWells on Sun 14 Feb 2016, 6:45 pm

Hi Mike,

Using the MEP-Cravens105\MEP-Cravens105R as a starting point scroll down the eng. file until you find the last light entry; ignore the lines coloured RED and copy and paste the middle section into your eng. file
Light (
comment( AI Red Right )
Type ( 0 )
Conditions (
Control ( 1 )
Service ( 2 )
Unit ( 3 )
)
FadeIn ( 0.5 )
FadeOut ( 0.5 )
Cycle ( 0 )
States ( 1
State (
Duration ( 0.0 )
LightColour ( ccff0000 )
Position ( 0.97 1.75 -9.15 )
Azimuth ( -180.0 -180.0 -180.0 )
Transition ( 0 )
Radius ( 0.25 )
Elevation ( 0 0 0 )
)
)
)
)
Sound ( "..\\..\\common.MEP\\1st_Gen_DMU\\dmueng.sms" )
)

Engine ( MEP-Cravens105R

Effects
(
DieselSpecialEffects
(
comment
(
the format of these little blocks is as follow:

offset.x offset.y offset.z
normal.x normal.y normal.z
width in metres

defining the offset from the shape pivot point
where steam / smoke should appear, the direction
it should go and the width of the nozzle
)

Exhaust1
(
.600 3.900 9.1
0 1 0
0.1
)
Exhaust2
(
-0.600 3.900 9.1
0 1 0
0.1
)

)
)

Wagon ( MEP-Cravens105R )
Type ( Diesel )
MaxPower ( 300hp )
MaxForce ( 70kN )
MaxContinuousForce ( 70kN )
MaxVelocity ( 70mph )
WheelRadius ( 18.54in )
NumWheels ( 1 )
MaxTemperature ( 120 )
MaxOilPressure ( 90 )
MaxDieselLevel( 500gals
)

This should, at least make your DTCL visible.

Ged is quite right in that the wrong sms files have been used - the only advantage is that you can hear what you are driving.

Regards,

Stephen
avatar
StephenRWells

Posts : 428
Join date : 2013-07-15
Age : 66
Location : Arncott,Oxfordshire

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  slipperman12 on Sun 14 Feb 2016, 7:01 pm

Hi Stephen,
Even with the 'Trailer' sms files used, the sound from the other vehicle can still be heard and when viewed from outside, it's more realistic as the engine sounds only come from the powered vehicle!

Cheers,
Ged

slipperman12

Posts : 1264
Join date : 2013-01-29
Age : 75
Location : North Nottinghamshire

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  IsambardKingdomBrunel on Mon 15 Feb 2016, 1:55 pm

Hi again Stephen,

thanks very much for the further information and help.

Apart from doing it for me, i don't think there is much more you could have done buddy. Very Happy

Much thanks and appreciation again.

Mike.
avatar
IsambardKingdomBrunel

Posts : 36
Join date : 2013-07-22
Age : 66
Location : South West Wales

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  IsambardKingdomBrunel on Sat 09 Sep 2017, 2:14 pm

If you are still around Stephen. Very Happy

I re-installed MSTS, OR & MEP today after many months of not running any of it.

You're DTCL fix worked a treat, thank you. Cool

Much appreciated,
Mike.
avatar
IsambardKingdomBrunel

Posts : 36
Join date : 2013-07-22
Age : 66
Location : South West Wales

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  StephenRWells on Sun 10 Sep 2017, 5:15 pm

Hi Mike,

Glad to have been of help and that all is now working properly.

Regards,

Stephen
avatar
StephenRWells

Posts : 428
Join date : 2013-07-15
Age : 66
Location : Arncott,Oxfordshire

Back to top Go down

Re: MEP Incomplete 105 DMU sets & Non Functioning Distant Signals.

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum