Bugs in Open Rails

Page 2 of 2 Previous  1, 2

View previous topic View next topic Go down

Re: Bugs in Open Rails

Post  slipperman12 on Tue 01 Sep 2015, 1:56 pm

Hi David,
I understand, and agree with everything you've said.

Your example of crew for an A4 and 0-6-0 saddle tank would also show incorrectly in MSTS - it would not be an incompatibility in Open Rails because it would (should) also display the same.

My discussion is based on the fact that MSTS allows tender-based crew FAs to be adjusted vertically, but OR doesn't. If the tender-based crew FA has its first parameter as zero (ie the shape is positioned at its origin, or as adjusted by Shape File Manager), OR displays it correctly. My contention is that the coding in OR somehow uses a small value in the first parameter (height above origin) to display the shape x metres in front of where it should be.

I believe, although I haven't tested it recently, that Open Rails processes a tender diminishing fuel FA correctly - the first parameter is the shape's starting position and the second, its final position, with the former always being higher than the latter.

Cheers,
Ged

slipperman12

Posts : 1227
Join date : 2013-01-29
Age : 75
Location : North Nottinghamshire

Back to top Go down

Re: Bugs in Open Rails

Post  slipperman12 on Thu 03 Sep 2015, 8:57 pm

Hi All,
I'm pleased to let you know that the "crew FA on a tender" problem has been fixed Smile

It is available with effect from the x3241 Open Rails release. As far as I know, nobody, other than Carlo Santucci and myself, has tested this fix, so please do so, and let me know of any problems.

Cheers,
Ged

slipperman12

Posts : 1227
Join date : 2013-01-29
Age : 75
Location : North Nottinghamshire

Back to top Go down

Page 2 of 2 Previous  1, 2

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum