Apology for Route Directory Error EB’s ECE parts 1 – 4

View previous topic View next topic Go down

Apology for Route Directory Error EB’s ECE parts 1 – 4

Post  j3801 on Thu 29 Jan 2015, 3:16 am

To all members of TSSH:

I have made a mistake with the install procedure for EuropeanBahn’s East Coast Express series.

I have recently had to reinstall this route due to a computer hiccup and found that for some reason the route did not want to work (I printed out the Route Directory entry for this route to make sure I was doing it properly). I used the CD’s to do the install and found that if I installed patch 3 (route part 2 update file from UKTS) after part 3 (Leed’s loop) had been installed it removed the Leed’s section.

The correct install should be: Route Part 1 (King’s Cross – Peterborough), Patch 1 (EastCoastExpressPart1_Update1.exe), Route Part 2 (Peterborough – York), Patch 2 (eb_ece2_ka_platform_signs.ace), Patch 3 (ece2_1.2.exe), Route Part 3 (Leed’s Loop), Patch 4 (LeedsLoopUpdate.exe), Route Part 4 (Hertford Loop), Patch 5 (EastCoastExpressPart2Activity5Update.exe).

[As an added awkward note: on disc 4 there is a 5th patch which fixes ECE 2 Act 5  (EastCoastExpressPart2Activity5Update.exe).]

On the otherhand the 5th add on in this collection (the Locomotives and activities collection) can be installed at any time during installation.

As I was the one who wrote this entry for the Route Directory I will take responsibility for this mistake and no one else, I personally apologise for all issues caused by my error.

Justin


Last edited by j3801 on Sat 03 Oct 2015, 5:51 am; edited 1 time in total


avatar
j3801
Admin

Posts : 477
Join date : 2013-01-17
Age : 32
Location : Kirrawee, Sydney, Australia

http://tsforum.freeclanforum.com

Back to top Go down

Re: Apology for Route Directory Error EB’s ECE parts 1 – 4

Post  sbowness on Thu 29 Jan 2015, 9:03 am

Hi Justin

I've just installed parts 1-3 but not the patches. The link to First Class in the Route Directory no longer works. I've tried shop-firstclass.com which takes me to their shop. I can only find Service Packs for Parts 1 and 3. I've installed them with no ill effects so far. The one problem I do have, and that is from the initial installation, is that Open Rails reports that one route, EC1-09, has not loaded properly and shows in the drop box as "load error: GC-09". MSTS doesn't seem to complain.

Should I still install the patches and, if so, how? I've found four of them in the UKTS downloads.

Cheers


Stephen
avatar
sbowness

Posts : 132
Join date : 2014-12-29
Age : 51
Location : Auckland, New Zealand

Back to top Go down

Re: Apology for Route Directory Error EB’s ECE parts 1 – 4

Post  j3801 on Fri 30 Jan 2015, 7:56 am

Hi Stephen,

I am not too sure about the OpenRails issue as I use MSTS myself.

As for the patches, 3 of the ones on UKTS are needed (the LL_NewRoads_fix.zip patch I have found is not needed.) The patches from First Class simulations (EastCoastExpressPart1_Update1.exe and LeedsLoopUpdate.exe) are however needed as the address certain issues with the route.
To be honest the missing signals patch (ECE_Grantham_Patch.zip) had been released after the Route Directory entry had been made and I had forgotten about it. I can be installed after Part 3 (Leeds Loop) or part 4 (Hertford Loop) is installed. So there are in fact 6 patches total.

My best advice is unfortunately that you need to uninstall ECE and start again, installing the patches as you go.

Justin


avatar
j3801
Admin

Posts : 477
Join date : 2013-01-17
Age : 32
Location : Kirrawee, Sydney, Australia

http://tsforum.freeclanforum.com

Back to top Go down

Re: Apology for Route Directory Error EB’s ECE parts 1 – 4

Post  sbowness on Fri 30 Jan 2015, 8:10 am

Thanks Justin. At least these uninstall easily.


Stephen
avatar
sbowness

Posts : 132
Join date : 2014-12-29
Age : 51
Location : Auckland, New Zealand

Back to top Go down

Re: Apology for Route Directory Error EB’s ECE parts 1 – 4

Post  j3801 on Fri 30 Jan 2015, 10:19 am

Hi Everyone,

You will all soon get sick of me with this but in a bid to be 100% accurate I have reinvestigated the install order in light of the other patches.

The correct install order is as follows:

  • Route Part 1 (King’s Cross – Peterborough)
  • Patch 1 (EastCoastExpressPart1_Update1.exe)
  • Route Part 2 (Peterborough – York)
  • Patch 2 (eb_ece2_ka_platform_signs.ace)
  • Patch 3 (ece2_1.2.exe)
  • Route Part 3 (Leed’s Loop)
  • Patch 4 (LeedsLoopUpdate.exe)
  • Patch 5 (ECE_Grantham_Patch.zip)
  • Route Part 4 (Hertford Loop)
  • Patch 6 (EastCoastExpressPart2Activity5Update.exe)


The patch LL_NewRoads_Fix.zip is only needed if you have new roads installed as it corrects a file fault that is caused by new roads. (I have installed this route into a clean install of MSTS with the only additions being the SD40-2, Class 50, MSTS V1.4 update and MSTS Bin V1.8. I have not installed X-tracks or New Roads).
Note: even though there is a number of recommendations that state installing patch 3 (ece2_1.2.exe) after Leeds Loop if you do this it will remove the Leeds loop section and you will need to reinstall that part (I just did a fresh install whilst writing this post to make sure I was accurate).

Justin


Last edited by j3801 on Sat 31 Jan 2015, 7:14 am; edited 1 time in total (Reason for editing : Correcting the SD40-2)


avatar
j3801
Admin

Posts : 477
Join date : 2013-01-17
Age : 32
Location : Kirrawee, Sydney, Australia

http://tsforum.freeclanforum.com

Back to top Go down

Re: Apology for Route Directory Error EB’s ECE parts 1 – 4

Post  glasgowworks on Sun 22 Feb 2015, 12:33 pm

Hi Justin

Downloaded all the patches, but I can't find EastCoastExpressPart2Activity5Update.exe anywhere.

Cheers Very Happy
Alistair Cowell
avatar
glasgowworks

Posts : 92
Join date : 2013-01-23
Age : 29
Location : Dumbarton, near Glasgow, Scotland

Back to top Go down

Re: Apology for Route Directory Error EB’s ECE parts 1 – 4

Post  rufuskins on Sun 22 Feb 2015, 3:26 pm

Is the patch not on Disc 4 then? I haven't reinstalled this route yet!


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3354
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: Apology for Route Directory Error EB’s ECE parts 1 – 4

Post  Scampispeedway on Sun 22 Feb 2015, 4:20 pm

Hi Alec, I've looked on both the Parts 3 and 4 Disc's and cannot find this patch so I also would be
interested to know how to get it.
Having said that I've done all the Activities for this Route and not come across any problems.

Bob
avatar
Scampispeedway

Posts : 120
Join date : 2013-01-22
Age : 70
Location : Newcastle upon Tyne

Back to top Go down

Re: Apology for Route Directory Error EB’s ECE parts 1 – 4

Post  j3801 on Sun 26 Apr 2015, 6:31 am

Hi Eveyone,

Just to update on this, it would appear that newer Hertford Loop discs have the patch whilst older ones don't. Unfortunately I don't know what the switch date is when this patch started to be included.

I would like to put it to the community as to what they think of the inclusion of this patch on the install order list for ECE in the routes directory? Should it be listed or not as it is causing a bit of confusion?

Justin


avatar
j3801
Admin

Posts : 477
Join date : 2013-01-17
Age : 32
Location : Kirrawee, Sydney, Australia

http://tsforum.freeclanforum.com

Back to top Go down

Re: Apology for Route Directory Error EB’s ECE parts 1 – 4

Post  Markh5682 on Sun 26 Apr 2015, 11:40 am

Hi Justin.

I take it that installing the patch on an installation that is already patched won't do any harm, if that is the case I would include it in the list.


Mark
avatar
Markh5682

Posts : 2544
Join date : 2013-01-21
Age : 62
Location : Lancashire

http://www.youtube.com/user/markh5682

Back to top Go down

Re: Apology for Route Directory Error EB’s ECE parts 1 – 4

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum