My LNWR NC Coach consists won't show in MSTS?

View previous topic View next topic Go down

My LNWR NC Coach consists won't show in MSTS?

Post  rufuskins on Thu 07 May 2015, 6:55 pm

Having tweaked the models for my 42 ft NC Coaches (radial bogie versions) I have created some simple consists to see how they run.
All models displayed OK in Shape Viewer.
All models passed through Route Riter with no reported errors.
No indication of errors when Train Store opened and consist selected for a run in Explore Mode. (I currently don't have Conbuilder installed!)
Route and location selected in Train Store and Run clicked.
MSTS opens and I arrive at screen where locomotive and consist is indicated and I click Run.
First stage runs OK but half way through second stage MSTS closes and reverts back to Train Store, but with NO error message!
I have tried several different approaches but the same result ensues.
I assume that there is an error within my coach WAG file, but it is not obvious to me at this time.
I would therefore welcome any suggestions as to where the fault might lie?
In hope, Alec


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3343
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  35005CP on Thu 07 May 2015, 7:31 pm

Have you run them through PolyMaster?


Andy - TSSH Footplate Crew
avatar
35005CP

Posts : 1617
Join date : 2013-01-23
Age : 38
Location : East Sussex

http://nineelms.freeforum.me.uk/

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  rufuskins on Thu 07 May 2015, 8:52 pm

35005CP wrote:Have you run them through PolyMaster?

No I don't currently have it installed in the new PC, and to be honest I never understood what it did and how it did it! Embarassed  Embarassed  Embarassed


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3343
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  Bob Latimer on Thu 07 May 2015, 9:14 pm

Alec,

If you want to send them my way I'll see if I can figure out what's happening.

Regards,

Bob.

Bob Latimer

Posts : 139
Join date : 2013-01-18
Age : 68
Location : Auckland, New Zealand

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  rufuskins on Fri 08 May 2015, 8:36 am

Bob
Thanks for your kind offer and I'll pop them onto Dropbox in the next few minutes.


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3343
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  j3801 on Fri 08 May 2015, 10:37 am

Hi Alec,

I you need some help I have a 3 day weekend so you can send them to me as well if you want.

Justin


avatar
j3801
Admin

Posts : 477
Join date : 2013-01-17
Age : 32
Location : Kirrawee, Sydney, Australia

http://tsforum.freeclanforum.com

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  rufuskins on Fri 08 May 2015, 7:51 pm

Thanks Justin;I've sent the MSTS files via Dropbox.


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3343
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  Bob Latimer on Fri 08 May 2015, 11:16 pm

Hi Alec.

I've tried everything I can think of but haven't been able to come up with a solution.

What I did was to concentrate on LNWR_42ft_BCL_D228_5852_Auto.wag

I created a consist with a loco and that carriage and tried to load it in MSTS. The progress bar got about half way across and stopped. The hard drive was flickering for quite a while and then MSTS crashed to the desktop.

It opened okay in Shape Viewer.

I ran it through Engmod (to check the brackets), Route_Riter and Conbuilder but they all came out clean.

I started with another .wag file from a carriage that I knew worked okay, changed the file name, the internal name and the shape file name but got the same crash.

I ran the shape file through MSTS Shape Fixer and it didn't find any problems.

I tried uncompressing and recompressing the shape file with Shape File Manager but no change to the result.

I tried opening each .ace file in TGATool2A and they all opened and looked okay. I'm stumped.

Regards,

Bob.


Bob Latimer

Posts : 139
Join date : 2013-01-18
Age : 68
Location : Auckland, New Zealand

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  35005CP on Fri 08 May 2015, 11:46 pm

Bob Latimer wrote:Hi Alec.

I've tried everything I can think of but haven't been able to come up with a solution.

What I did was to concentrate on LNWR_42ft_BCL_D228_5852_Auto.wag

I created a consist with a loco and that carriage and tried to load it in MSTS.  The progress bar got about half way across and stopped.  The hard drive was flickering for quite a while and then MSTS crashed to the desktop.

It opened okay in Shape Viewer.

I ran it through Engmod (to check the brackets), Route_Riter and Conbuilder but they all came out clean.

I started with another .wag file from a carriage that I knew worked okay, changed the file name, the internal name and the shape file name but got the same crash.

I ran the shape file through MSTS Shape Fixer and it didn't find any problems.

I tried uncompressing and recompressing the shape file with Shape File Manager but no change to the result.

I tried opening each .ace file in TGATool2A and they all opened and looked okay.  I'm stumped.

Regards,

Bob.


Hi Bob,

Did you try running them through PolyMaster?

Cheers

Andy


Andy - TSSH Footplate Crew
avatar
35005CP

Posts : 1617
Join date : 2013-01-23
Age : 38
Location : East Sussex

http://nineelms.freeforum.me.uk/

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  Bob Latimer on Sat 09 May 2015, 12:17 am

Sometimes I surprise myself!

Not being a model builder I've never used Polymaster before but I thought I'd have a go. After all, there's not much I could destroy!

I downloaded Polymaster, had a look at it and decided I was in way above my head. So, more by luck than good judgement, here's what I did:

- On the Splitting screen I hit the Compress/Decompress .s button and chose LNWR_42ft_BCL_D228_5852.s
- I then pressed the Open button and opened the same file.
- I then pressed the buttons on the lower right in order, starting with Make LODs/Subobjects and ending with Correct TSM Mat. Error
- Then I pressed Save and then Compress/Decompress .s again.

Lo and behold, the carriage now shows up in MSTS.

Fantastic!

Bob.

Bob Latimer

Posts : 139
Join date : 2013-01-18
Age : 68
Location : Auckland, New Zealand

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  rufuskins on Sat 09 May 2015, 9:05 am

Mmmmmmmmmmmmm . . .

I have just repeated the same method and it too worked! So I can obviously repeat the process for all of the models and get them to show, which in and of itself is great news! Mind you I'd love to know what the actual problem(s) was(were) in order to avoid it(them) again. I presume it must relate to the way I built up the model, but . . ?

Thanks Bob for putting your toe in the water for me! I suppose I should not have been so timid! Embarassed  Embarassed  Embarassed

PS: To I have just realised that to make matters worse I put my name to an HFL Part HERE on the subject of Polymaster! Embarassed Embarassed Embarassed Embarassed Embarassed
It just goes to show that you should be very careful about what you put your name to, and that I need to improve my short term memory!


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3343
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  35005CP on Sat 09 May 2015, 10:40 am

Glad I could help!!!!.......... Cool


Andy - TSSH Footplate Crew
avatar
35005CP

Posts : 1617
Join date : 2013-01-23
Age : 38
Location : East Sussex

http://nineelms.freeforum.me.uk/

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  rufuskins on Sat 09 May 2015, 11:53 am

35005CP wrote:Glad I could help!!!!.......... Cool

Much appreciated!


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3343
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  rufuskins on Sat 09 May 2015, 12:56 pm

All 30 models run through Polymaster and every time the routine asked me to "Weld Together Points" and "Weld Together Normals". Again I assume that this reflects the way that I build up my models and suggests that in that process coincident points are not quite coincidental?
Anyway I created a consist with a Claughton up front - probably should really be a tank engine - and a number of different coach diagrams, and here is the result:-



Thank you to everyone who helped put me right, much appreciated.  OK

I now need to understand about LODs? I know that LOD stands for Level Of Detail and relates to what can be seen at various distances. I assume its meant to reduce the level of detail the further you are from the object, and hence reduces the strain on MSTS?


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3343
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  rufuskins on Sat 09 May 2015, 3:04 pm

I have just read an email from Justin that has clearly explained what I need to do when using Polymaster, and it would appear that the actions done for the previous post were OK but needed some initial tweaking of Polymaster to produce a more efficient item of stock for MSTS. I shall revisit them using Justin's guide and see what the results are.


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3343
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  rufuskins on Sat 09 May 2015, 6:40 pm

Well I'll be honest and say that rather than repeat Justin's "polymastering" of my coaches, I have used his work on the 15 I sent for checking, and then used the revised S files in the duplicated and renumbered second versions.
Very many thanks Justin.


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3343
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  Bob Latimer on Sun 10 May 2015, 2:41 am

Well I did say my sledge hammer approach produced a positive result more by luck than by good judgement. Very Happy

Bob Latimer

Posts : 139
Join date : 2013-01-18
Age : 68
Location : Auckland, New Zealand

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  rufuskins on Sun 10 May 2015, 7:27 am

Sometimes a "sledge hammer" approach produces the best results, and you certainly showed me that there was nothing to fear using Polymaster. Thank you.


ALEC - Supporter of MSTS and TSSH!

rufuskins

Posts : 3343
Join date : 2013-01-17
Age : 68
Location : Milnrow, Lancashire

Back to top Go down

Re: My LNWR NC Coach consists won't show in MSTS?

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum